Как я могу установить Центр программного обеспечения чтобы установить программное обеспечение для непривилегированных пользователей?

Как можно установить Центр программного обеспечения, чтобы позволить обычным пользователям устанавливать разный софт из репозитория Ubuntu без ввода пароля?

Я полностью осознаю последствия для безопасности, и я готов рискнуть. В Fedora 12 поставляется с что-то вроде этого. (Путем изменения конфигурации policykit теперь, я считаю)

+948
user1330213 18 июл. 2014 г., 4:56:46
18 ответов

Я работаю в подобной среде, и я решил проблему следующим образом:
1) установить и настроить CNTLM:
судо apt-получить установку cntlm
судо нано /etc/cntlm.конф
2) ввести в cntlm.конф настройки прокси и логин и пароль для вашей сети
3) в браузере(ов) настройки прокси чтобы http://localhost:3128/
4) добавляете эти 3 строки в ~/.bashrc или в глобальный файл /etc/Баш.bashrc следующее
экспорт при=HTTP://локальный:3128/
экспорт https_proxy=http://локальный:3128/
экспорт ftp_proxy=http://локальный:3128/
5) выйти из системы и войти снова: все должно работать!









Пока

+917
Holly408 03 февр. '09 в 4:24
Асимметричная Цифровая Абонентская Линия
+895
user691577 7 нояб. 2012 г., 19:34:21

Я просто заметил, что Худ исчез. Я обновил до 13.04 в последнее время и нажав клавишу Alt ничего не делает. Этот значок (кран) ярлык даже ушел из шпаргалку, которая появляется, когда я держу супер.

Это нормально?

+837
mortona42 2 янв. 2017 г., 13:15:53

Единство будет по умолчанию в 11.04 (в настоящее время не издавался), а не 10.10.

Для того чтобы установить единство в 10.10 Desktop версия взглянем на этот вопрос.

+829
Joseph Reckers 14 апр. 2015 г., 3:20:37

Я добавил Все компания fluendo кодеки. Сейчас я пробовал Баньши и rythmbox, проблема, похоже, сохраняются, хотя звук, производимый, когда я вперед не так раздражает, как это было. Я использую Ubuntu 10 ЛЦ, и GStreamer 0.10 ffmpeg с 0.10-10-1, для GStreamer 0.10-pitfdll 0.9.1.1 cvs200802 и для GStreamer 0.10 компания fluendo-MP3 и 0.10.12.в Debian 2

Есть ли смысл? Я единственный, кто имеет аналогичную проблему?

В любом случае, я думаю, что VLC отличную репутацию хорошо защищены. Я использовал на Windows, Linux и Mac, и имеют очень мало проблем с ним.

Привет.

+727
Jorma Rebane 11 апр. 2014 г., 16:34:11

Вы должны запустить команду sudo texhash обновить латексной базе местных пакетов. Без этого, латекс не могу их найти.

+709
ejr 11 окт. 2015 г., 0:42:48

Возможные Дубликаты:
Как я могу исправить ошибку 404 с помощью ППА?
Менеджер обновлений выдает ошибку 404 при попытке обновления. Не буду обновлять

Когда я попытался установить JDK от следующей команды:

судо apt-получить установку пакеты OpenJDK-7-JDK и

Следующее сообщение об ошибке отображается:

Подстраховаться http://us.archive.ubuntu.com/ubuntu/ точный-обновления/Вселенная

 пакеты OpenJDK-7-JRE и делали все 7u7-2.3.2-1ubuntu0.12.04.1
 404 не найдена [ИС: 91.189.91.15 80]

Е: невозможно получить некоторые архивы, может запустить apt-получить обновление или попробовать с --исправить-отсутствует?
+706
Terry Li 6 янв. 2018 г., 17:56:23

Сообщение об ошибке означает, что ваш процессор не поддерживает PAE, так наращивание - это метод, который позволяет 32-битный процессор с более чем 4 ГБ оперативной памяти адресное пространство.

По умолчанию, 12.04 и более поздние версии Ubuntu ожидает процессор с этой возможностью:

Паэ предоставляется компанией Intel процессор Pentium Pro и выше процессоров, включая все позже Процессор Pentium-процессоров серии (кроме 400 версий МГц-шина Pentium м). Она также доступна на других процессорах с аналогичными или более продвинутые версии одной и той же архитектуры, таких как AMD Атлон[сомнительных – обсудить] и более поздних моделях процессоров AMD. Википедия

В то время как выше, является строго истинной, старой системы, которые имеют контроллер памяти на материнской плате не может "разоблачить" поддержка PAE процессора, эффективно делая их отличных от физических.

В отеле есть подогреваемый баг-репорт об этом, в Canonical решили, что по умолчанию в Ubuntu установка на компьютер будет ожидать поддержки PAE.

Несколько возможных решений:

Способ 1: Установка с Lubuntu или Xubuntu в, затем установите обычную Убунту рабочего стола

  • Установить либо с Lubuntu 12.04 32-бит или Xubuntu в 12.04 32-бит; оба эти использовать PAE ядра по умолчанию.
  • После загрузки в ваш новый с Lubuntu/Xubuntu в, Затем можно переключиться на Unity по умолчанию рабочего стола, установив Убунту-десктоп пакет.

Решение 2: установить старую версию и затем обновить до 12.04

Установить 10.04 или 11.10 и затем обновить до 12.04. Увидеть связан вопрос ниже по 12.10.

Способ 3: Если у вас есть проводное подключение к интернету, используйте "чистую установку" мини-CD

  • Вам понадобится достаточно быстрый проводной связи для этого метода-все пакеты будут загружаться через интернет.
  • Скачать нон-Пае сетевой загрузки образов дисков mini.iso и записать его на CD или USB.
  • Загрузитесь с него, выполните шаги, и выбрать документацию , когда его спросили, чтобы выбрать ядро, а Убунту-десктоп , чтобы получить "по умолчанию" Убунту установки обычного настольного диска дал бы тебе, просто с не-PAE ядра.
    • Вы также можете выбрать один из других компьютеров. Вы должны выбрать столе, в противном случае вы не имеет графического интерфейса, чтобы играть после установки.

Решение 4: в Ubuntu 12.04.5 и 14.04 (или позже) на Pentium M только

  • В Ubuntu 12.04.5 и поддержка 14.04 вариант ("forcepae"), чтобы включить PAE на процессорах Pentium м (где она отключена по умолчанию). Чтобы включить это:

    • Загрузить 32-битную Убунту (или Xubuntu В и т. д.) установщик
    • Когда изображение клавиатуры и маленький человек в круге появляется нажмите клавишу Tab
    • "Выбор языка" появляется всплывающее окно. Используйте клавиши управления курсором и нажать клавишу Enter, чтобы выбрать ваш язык
    • Нажмите клавишу F6, серый меню всплывающее окно с несколькими вариантами загрузки
    • Нажмите клавишу Escape, чтобы закрыть окно
    • Сейчас вы увидите строку, которая говорит:

    Параметры файла boot=/cdrom/и автоматизации/Убунту.семян загрузиться=Каспер и initrd=/Каспер/и initrd.ЛЗ тихий всплеск --

    Отредактировать эту строку и добавить forcepae параметр с пробелами два раза вокруг -- в конце:

    Параметры файла boot=/cdrom/и автоматизации/Убунту.семян загрузиться=Каспер и initrd=/Каспер/и initrd.ЛЗ тихий всплеск forcepae -- forcepae

    • forcepae -- forcepae Примечание:

      forcepae необходимо дважды, потому что он задает параметры загрузки на два разных ядра сапоги - ядра, который выполняется в рамках программы установки (слева от --), и ядром, которое работает на установленной системе (права --).

      Текст в конце должно быть -- forcepae не --forcepae. Есть пространство между -- и forcepae

    • Нажмите клавишу Enter, надеюсь, Убунту загружается и остальные ваши установки будут успешными. Если у вас есть графические проблемы с единством, или просто найти его медленно, попробуйте более легкий дистрибутив Xubuntu в как.


Связанный Вопрос:

  1. Как я могу сказать, если машина имеет Паэ?
  2. Можно ли будет использовать PAE ядра в последних версиях Ubuntu?
+660
gies0r 5 мая 2010 г., 18:23:33

У меня есть двойной загрузки ноутбук ASUS K42J (с Нэтти 11.04. и Maverick 10.10). Нэтти 11.04 была свежеустановленная, а потом через пару месяцев я установил Маверик рядом (просто для эксперимента).

Я могу открыть все мои сетевые папки под аккуратна, без каких-либо проблем (НАН, выиграть 7 ноутбук и 2 медиаплеерах), но Самба не работает в Maverick - не вижу каких-либо акций. Я использовал для самбы в Maverick такая же установка как у меня под Нэтти.

Есть ли разница между настройками самбы в 10.10 и 11.04 ? Было бы здорово, если кто-то может помочь мне заставить работать Самбу Скиталец.

+631
Geek Zero 11 мар. 2014 г., 1:55:54

у меня есть Ubuntu сервер, который я использую, чтобы получить к нему доступ через DDNS & Ubuntu сервер работает в качестве гостевой ОС

Сервисы, запущенные на сервере Ubuntu

  1. Апач
  2. СШ
  3. ДНС
  4. Самба

я также ищу инструменты, которые напишите Мне, если кто-то пытается что-то сделать ( если это возможно )

+587
annant vijay 16 янв. 2011 г., 1:43:25

Я считаю, что вы должны установить Ndisgtk, нажав здесь. Я не проверял это сам, так что я надеюсь, будет ясно, когда вы просто запустите это приложение.

В противном случае, я думаю, есть информация по этой теме на форум Ubuntu.

+580
Murtaza Lakhani 31 мая 2012 г., 9:41:10

По аналогичной должности в другом месте, Пуа расшифровывается как "потенциально нежелательные приложения" и сценарий.упакованные "обычно означает, что он был упакован с помощью то, что вызывает AV предупреждения из-за метода, используемого для пакета программного обеспечения для установки".

Он идет дальше и говорит, что

Сотни мелких разработчики получают смехотворные "ты дал моей ПК вирусов электронной почты" просто потому, что они решили использовать упаковщик для построить свои установки.

В качестве другого ответа здесь указывается, если вы получили пакеты, установленные из репозиториев, наверное, это тоже ложное срабатывание.

Редактировать: для веб-сайтов, по крайней мере, здесь и здесь, это исключено, так как ложно-положительный, но вы всегда можете загрузить файл в VirScan.org чтобы проверить несколькими антивирусами.

+537
Penelope Cox 21 нояб. 2014 г., 9:47:54

Из этой вики-странице http://www.thinkwiki.org/wiki/Category:W510

Добавьте следующее В разделе Устройство для файла xorg.conf и перезапустить Х.

Вариант "RegistryDwords" "EnableBrightnessControl=1"

Страница имеет дополнительные советы по модели W510

+497
Sharleen Johnson 15 янв. 2014 г., 15:05:35

Вы можете также запустить гном-панели в единстве, видеть, как использовать панели GNOME в Unity?

+378
apat 29 апр. 2018 г., 0:35:54

Есть ли способ, чтобы установить регион для сенсорной панели как "мертвый", игнорируя сенсорный ввод?

Причина этого заключается в том, что у меня есть MacBook Pro в конце 2011 года и есть "кнопка" на ощупь страницы.

Кто-нибудь есть идеи? :Д

+250
Jaheel 23 сент. 2014 г., 1:54:06

Ваш ноутбук нуждается в проприетарных драйверов для беспроводных функции (в отличие от открытого источника). Люди столкнулись с проблемами с драйверами, хотя она и уменьшилась с более новой версии Ubuntu. Нечего делать;Ubuntu поставляется расфасованный с проприетарными драйверами (по крайней мере для моей модели).

+219
kibblewhite 18 мар. 2012 г., 1:38:01

Я скачал файл под названием MultiMC. Я привык к Windows, где все нужно расширение файла для запуска. Про этот файл, он имеет расширение. Согласно инструкции, я должен пометить его как исполняемый файл, а затем дважды щелкните по нему. поэтому я отметил его и дважды нажал и ничего не произошло. Я попробовал спам щелкнув его, который ничего не сделал в итоге. Я использую последние сборки Ubuntu и я знаю, другие люди, используя эту программу в Ubuntu, а также. Я не знаю, как правильно использовать терминал. скажите, пожалуйста, что я делаю неправильно и, пожалуйста, упростить его как можно больше. Спасибо!

+153
Carlos Vigil 5 авг. 2012 г., 3:56:25

Возможные Дубликаты:
Что делать, когда Убунту зависает?

Мой компьютер является Dell настольный компьютер OptiPlex 380, оригинальной операционной системы является Ubuntu 11.04, и я обновил ее до 12.04 прямо сейчас. После перезагрузки, клавиатура отмороженные, и монитор не загорается.

Кажется, драйвера видеокарты некорректно и USB-порт не работает.

Пожалуйста, помогите мне, это имеет очень важные данные в нем ......

+121
baoye 3 нояб. 2015 г., 19:19:02

Показать вопросы с тегом